Никита К.
26 лет, Россия
1594 сообщения
#9 лет назад
Прошло полгода с тех пор, как я использую Linux в качестве основной операционной системы (WinXP только на VirtualBox'e и только для Delphi и WMKeeper)

Версию ставил тогда Linux Ubuntu 9.04
Сейчас решил обновить. До 9.10 (как предложил update-manager)

После установки всех пакетов и перезагрузки система грузится только в консольном режиме.

Что пробовал:
$ startx
$ sudo /etc/init.d/gdm start
$ sudo aptitude reinstall ubuntu-desktop
$ sudo aptitude reinstall gdm
$ sudo apt-get --reinstall install xserver-xorg

Результат везде одинаковый - никакой
Может кто-нибудь подсказать чтобы ещё такого попробовать?

P.S Сейчас загрузился с LiveCD, устанавливать систему с нуля не хочу
P.P.S Работать в консольном режиме тоже не могу))

Заранее "Спасибо!" всем откликнувшимся
Александр Соколов
Россия
1050 сообщений
#9 лет назад
Не знаю, как на Убунте, но на фряхе я правил кучу конфигов, чтобы прикрутить КДЕ или Гном. А когда все таки пропатчил, я понял, что никсы с гуем - вещь ничем не лучше винды, но зато софта под нее гораздо меньше.
Александр Вовченко
34 года, Россия
771 сообщение
#9 лет назад
Убунта основная ось с 8.04 Ни разу не удалось обновиться легко и непринуждённо, постоянно какой-то косяк да вылезал.

В итоге приходится переустанавливать без полного форматирования винчестера. /home сохраняется, соответственно настройки остаются на месте.
Месяц назад поставил Mint 9 Isadora - нравится всё больше и больше
Никита К.
26 лет, Россия
1594 сообщения
#9 лет назад
То есть по вашему лучше переустановить полностью и всё?..
А софт весь сохранится? Настройки - да, а вот сам софт...
Виктория К.
32 года, Украина
3522 сообщения
#9 лет назад
Я с убунту 2 месяца
Никита К.
26 лет, Россия
1594 сообщения
#9 лет назад
kravtsovaV, поздравляю)
Андрей Костин
37 лет, Россия
1172 сообщения
#9 лет назад
Как минимум надо сначала обновиться до 10.04 через консоль. А потому уже пытаться настраивать.
Александр Вовченко
34 года, Россия
771 сообщение
#9 лет назад
Цитата ("Anexroid"):
А софт весь сохранится? Настройки - да, а вот сам софт...

разумеется, не сохранится. Лично мне это не особо и надо, т.к. sudo apt-get install apache2 mysql php5 svn jre решает все проблемы остальное из коробки
Андрей Костин
37 лет, Россия
1172 сообщения
#9 лет назад
Инструкция с оф.сайта по обновлению
Install the update-manager-core package if it is not already installed; edit /etc/update-manager/release-upgrades and set Prompt=normal; launch the upgrade tool with the command sudo do-release-upgrade -d; and follow the on-screen instructions.


Цитата ("alexander_vip"):
sudo apt-get install apache2 mysql php5 svn jre решает все проблемы

sudo apt-get install lamp-server^ svn jre решает еще больше проблем.
Никита К.
26 лет, Россия
1594 сообщения
#9 лет назад
Цитата ("Lisio"):
Как минимум надо сначала обновиться до 10.04 через консоль. А потому уже пытаться настраивать.

А подробнее можно? А то до 9.10 обновлялся через 'update-manager -d'
Андрей Костин
37 лет, Россия
1172 сообщения
#9 лет назад
Ну разве что переведу цитату, которую дал выше:
1. Установите пакет update-manager-core, если он еще не установлен
2. Отредактируйте /etc/update-manager/release-upgrades, установив Promt=normal
3. Запустите утилиту обновления через sudo do-release-upgrade -d и следуйте инструкциям.

Сам так не обновлял, сижу на кубунту.
Андрей Чепурной
36 лет, Украина
598 сообщений
#9 лет назад
Оффтопик
прошу прощения за вопрос не в тему... почему нужно ставить систему... которую нужно самому править... пытатся прикрутить КДЕ... искать софт который бы подходил... и тому подобное... зачем?
Владимир Ф.
36 лет, Россия
1322 сообщения
#9 лет назад
Anexroid, посмотри в логи для начала. Причина незапуска иксов хоть будет. /var/log/Xorg.0.log кажется.
Драйвер закрытый на видюху ставили? (до обновления)


droniator, совсем не в тему и может привести к срачу. Нравится вот и ставят. Кому нравится бесплатность. Кому вирусобезопасность. Кому красноглазить. А кому и для работы удобнее просто.
Андрей Костин
37 лет, Россия
1172 сообщения
#9 лет назад
droniator, вот мне надо к примеру поставить сервер, установить php, поставить мускуль и потом это спокойно обновлять, добавлять пакеты. Сколько инструкций вы мне приведете, чтобы сделать это на винде? Поставить денвер или xampp и каждый раз заниматься извратом с добавлением библиотек, невозможностью нормально работать с pear и т.д.?

Под иксами я это делаю строкой
apt-get install lamp-server^

Дальше рассказывать?
Андрей Чепурной
36 лет, Украина
598 сообщений
#9 лет назад
Я просто к тому что например у меня есть пару дисков с разными сборками Линукса... я пару раз ставил их себе... но потом все равно сносил... вот и хочу выяснить зачем он мне
Никита К.
26 лет, Россия
1594 сообщения
#9 лет назад
vovan_f, логи смотрел, но не понял... Драйвера стояли - с офф. сайта ATI

Обновил до 10.04
В резальтате написал что-то вроде

Updating successful.
Error:
Not installed:
xorg-driver-fglrx :!:
fglrx-kernel-source
fglrx-amdcccle
Александр Вовченко
34 года, Россия
771 сообщение
#9 лет назад
Цитата ("droniator"):
Я просто к тому что например у меня есть пару дисков с разными сборками Линукса... я пару раз ставил их себе... но потом все равно сносил... вот и хочу выяснить зачем он мне

раз вы задаёте себе этот вопрос - значит он вам ещё/вообще не нужен
Например, я с ужасом вспоминаю программирование на php в винде. А в убунте всё такое родное, удобное, "прямое"..
Владимир Ф.
36 лет, Россия
1322 сообщения
#9 лет назад
Хммм. c ati -не знаю. не сталкивался.
Знаю, что при обновлении центоси, закрытый драйвер от nvidia надо переставлять, т.к. он куда-то там в ядро код свой пишет.
А эти 3 пакета из консоли поставить не пробовал?

В логах смотри особенно на то что начинается с "(EE)"
/etc/X11/xorg.conf в студию ))
Никита К.
26 лет, Россия
1594 сообщения
#9 лет назад
Пробовал устанавливать изрепозитория - бесполезно. Не хочет, выдаёт ошибки

Снёс иксы, поставил заново.
Теперь выдают not found screen(вроде)

Не ставится fglrx. Думаю проблема в нём.
Владимир Ф.
36 лет, Россия
1322 сообщения
#9 лет назад
Anexroid, вам никто тут не поможет, если вы не будете писать, что за ошибки оно выдает.
Как говориться "Телепаты в отпуске".
А иксы сами конфигурироваться разве должны?
После установки Xorg -configure для создания конфига иксов не запускали?